102- Ecological Bin Packing

Problem Description
source: https://uva.onlinejudge.org/external/1/p102.html

Bin packing, or the placement of objects of certain weights into different bins subject to certain constraints, is an historically interesting problem. Some bin packing problems are NP-complete but are amenable to dynamic programming solutions or to approximately optimal heuristic solutions.
    In this problem you will be solving a bin packing problem that deals with recycling glass.

    Recycling glass requires that the glass be separated by color into one of three categories: brown glass, green glass, and clear glass. In this problem you will be given three recycling bins, each containing a specified number of brown, green and clear bottles. In order to be recycled, the bottles will need to be moved so that each bin contains bottles of only one color.

    The problem is to minimize the number of bottles that are moved. You may assume that the only problem is to minimize the number of movements between boxes.
    For the purposes of this problem, each bin has infinite capacity and the only constraint is moving the bottles so that each bin contains bottles of a single color. The total number of bottles will never exceed 2 31 .

Input 

The input consists of a series of lines with each line containing 9 integers. The first three integers on a line represent the number of brown, green, and clear bottles (respectively) in bin number 1, the second three represent the number of brown, green and clear bottles (respectively) in bin number 2, and the last three integers represent the number of brown, green, and clear bottles (respectively) in bin number 3. For example, the line
                       10 15 20 30 12 8 15 8 31

indicates that there are 20 clear bottles in bin 1, 12 green bottles in bin 2, and 15 brown bottles in bin 3.
    Integers on a line will be separated by one or more spaces. Your program should process all lines in the input file. 

Output 

For each line of input there will be one line of output indicating what color bottles go in what bin to minimize the number of bottle movements. You should also print the minimum number of bottle movements.
    The output should consist of a string of the three upper case characters ‘G’, ‘B’, ‘C’ (representing the colors green, brown, and clear) representing the color associated with each bin
    The first character of the string represents the color associated with the first bin, the second character of the string represents the color associated with the second bin, and the third character represents the color associated with the third bin.
    The integer indicating the minimum number of bottle movements should follow the string.
     If more than one order of brown, green, and clear bins yields the minimum number of movements then the alphabetically first string representing a minimal configuration should be printed.

Sample Input 

1 2 3 4 5 6 7 8 9 
5 10 5 20 10 5 10 20 10 

Sample Output 

BCG 30 
CBG 50


Solution:
#include<stdio.h>

int main()
{
    long int a[7], i,b[5],g[5],c[5],small;
while(scanf("%ld%ld%ld%ld%ld%ld%ld%ld%ld",&b[1],&g[1],&c[1],&b[2],&g[2],&c[2],&b[3],&g[3],&c[3])==9)
    {
       a[1]=b[2]+b[3]+g[1]+g[2]+c[1]+c[3];
       a[2]=b[2]+b[3]+g[1]+g[3]+c[1]+c[2];
       a[3]=b[1]+b[3]+g[1]+g[2]+c[2]+c[3];
       a[4]=b[1]+b[2]+g[1]+g[3]+c[2]+c[3];
       a[5]=b[1]+b[3]+g[2]+g[3]+c[1]+c[2];
       a[6]=b[1]+b[2]+g[2]+g[3]+c[1]+c[3];
       small=a[1];
       for(i=2;i<7;i++)
       {
           if(a[i]<small)
            small=a[i];
       }
       for(i=1;i<7;i++)
       {
           if(a[i]==small)
           {
                if(i==1)
                    printf("BCG %ld\n",small);
                else if(i==2)
                    printf("BGC %ld\n",small);
                else if(i==3)
                    printf("CBG %ld\n",small);
                else if(i==4)
                    printf("CGB %ld\n",small);
                else if(i==5)
                    printf("GBC %ld\n",small);
                else
                    printf("GCB %ld\n",small);
                break;
           }
       }

    }
    return 0;
}
image

No comments:

Post a Comment

Write your comment - Share Knowledge and Experience