Solution of 10071 - Back to High School Physics

Problem Description
source:https://uva.onlinejudge.org/external/100/10071.html

A particle has initial velocity and acceleration. If its velocity after certain time is v then what will its displacement be in twice of that time? 

Input 

The input will contain two integers in each line. Each line makes one set of input. These two integers denote the value of v (−100 ≤ v ≤ 100) and t (0 ≤ t ≤ 200) (t means at the time the particle gains that velocity) 

Output 

For each line of input print a single integer in one line denoting the displacement in double of that time. 

Sample Input 

0 0 
5 12 

Sample Output 


120

Solution:
#include<stdio.h>
int main()
{
    int  v, t;
    while(scanf("%d %d",&v,&t)==2)
    {
             if(v && t)
                   printf("%d\n",(2*v*t));
             else
                  printf("%d\n",0);
    }
    return 0;
}
image

No comments:

Post a Comment

Write your comment - Share Knowledge and Experience