Solution of 10327 - Flip Sort

Problem Description
source:https://uva.onlinejudge.org/external/103/10327.html

Sorting in computer science is an important part. Almost every problem can be solved effeciently if sorted data are found. There are some excellent sorting algorithm which has already acheived the lower bound n · lg n. In this problem we will also discuss about a new sorting approach. In this approach only one operation (Flip) is available and that is you can exchange two adjacent terms. If you think a while, you will see that it is always possible to sort a set of numbers in this way. 
      A set of integers will be given. Now using the above approach we want to sort the numbers in ascending order. You have to find out the minimum number of flips required. Such as to sort ‘1 2 3’ we need no flip operation whether to sort ‘2 3 1’ we need at least 2 flip operations. 

Input 

The input will start with a positive integer N (N ≤ 1000). In next few lines there will be N integers. Input will be terminated by EOF. 

Output 

For each data set print ‘Minimum exchange operations : M’ where M is the minimum flip operations required to perform sorting. Use a seperate line for each case. 

Sample Input 


1 2 3 

2 3 1 

Sample Output 

Minimum exchange operations : 0 
Minimum exchange operations : 2

Solution:
#include<stdio.h>

int a[1005],n,flip;
void InsertionSort();
int main()
{
    int i,j;
    while(scanf("%d",&n)==1)
    {
        for(i=1;i<=n;i++)
            scanf("%d",&a[i]);
        InsertionSort();
        printf("Minimum exchange operations : %d\n", flip);
    }

    return 0;
}
void InsertionSort()
{
    int k,ptr,temp,set;
    flip=0;
    for(k=2;k<=n;k++)
    {
        temp=a[k];
        ptr=k-1;
        while(temp<a[ptr])
        {
            a[ptr+1]=a[ptr];
            ptr=ptr-1;
            set=1;
            flip+=1;
        }
        a[ptr+1]=temp;
    }
}
image

No comments:

Post a Comment

Write your comment - Share Knowledge and Experience