Solution of 11942 - Lumberjack Sequencing

Problem Description
source:https://uva.onlinejudge.org/external/119/p11942.html

Another tale of lumberjacks?. Let see . . . 

The lumberjacks are rude, bearded workers, while foremen tend to be bossy and simpleminded. The foremen like to harass the lumberjacks by making them line up in groups of ten, ordered by the length of their beards. The lumberjacks, being of different physical heights, vary their arrangements to confuse the foremen. Therefore, the foremen must actually measure the beards in centimeters to see if everyone is lined up in order. 

Your task is to write a program to assist the foremen in determining whether or not the lumberjacks are lined up properly, either from shortest to longest beard or from longest to shortest. 

Input 


The input starts with line containing a single integer N, 0 < N < 20, which is the number of groups to process. Following this are N lines, each containing ten distinct positive integers less than 100. 

Output 

There is a title line, then one line per set of beard lengths. See the sample output for capitalization and punctuation. 

Sample Input 


13 25 39 40 55 62 68 77 88 95 
88 62 77 20 40 10 99 56 45 36 
91 78 61 59 54 49 43 33 26 18 

Sample Output 

Lumberjacks: 
Ordered 
Unordered 
Ordered


Solution:
#include<stdio.h>

int main()
{
    int t,i,j, k, value[12],as,de;
    while(scanf("%d",&t)==1)
    {
        for(i=1;i<=t;i++)
        {
            for(j=1;j<=10;j++)
                scanf("%d",&value[j]);
            as=0;
            de=0;
            if(i==1)
                printf("Lumberjacks:\n");
            if(value[1]>value[2])
                for(k=1;k<10;k++)
                {
                    if(value[k]>value[k+1])
                      de++;
                    else
                        break;
                }
            else if(value[1]<value[2])
                for(k=1;k<10;k++)
                {
                    if(value[k]<value[k+1])
                      as++;
                    else
                        break;
                }
            if(as==9 || de==9)
                printf("Ordered\n");
            else
                printf("Unordered\n");
        }

    }
    return 0;
}
image

No comments:

Post a Comment

Write your comment - Share Knowledge and Experience