Solution of 406 - Prime Cuts

Problem Description
source:https://uva.onlinejudge.org/external/4/406.html

A prime number is a counting number (1, 2, 3, . . .) that is evenly divisible only by 1 and itself. In this problem you are to write a program that will cut some number of prime numbers from the list of prime numbers between (and including) 1 and N. Your program will read in a number N; determine the list of prime numbers between 1 and N; and print the 2C prime numbers from the center of the list if there are an even number of prime numbers or 2C − 1 prime numbers from the center of the list if there are an odd number of prime numbers in the list.

Input 

Each input set will be on a line by itself and will consist of 2 numbers. The first number (1 ≤ N ≤ 1000) is the maximum number in the complete list of prime numbers between 1 and N. The second number (1 ≤ C ≤ N) defines the 2C prime numbers to be printed from the center of the list if the length of the list is even; or the 2C − 1 numbers to be printed from the center of the list if the length of the list is odd.



Output 

For each input set, you should print the number N beginning in column 1 followed by a space, then by the number C, then by a colon (:), and then by the center numbers from the list of prime numbers as defined above. If the size of the center list exceeds the limits of the list of prime numbers between 1 and N, the list of prime numbers between 1 and N (inclusive) should be printed. Each number from the center of the list should be preceded by exactly one blank. Each line of output should be followed by a blank line. Hence, your output should follow the exact format shown in the sample output.

Sample Input 

21 2
18 2
18 18
100 7

Sample Output 

21 2: 5 7 11
18 2: 3 5 7 11
18 18: 1 2 3 5 7 11 13 17
100 7: 13 17 19 23 29 31 37 41 43 47 53 59 61 67

Solution:
#include <algorithm>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <stack>
#include <string>
#include <vector>
#include<stdio.h>
#include<stdlib.h>
#define max 1005

using namespace std;

void GenPrime();
long int prime[max];
long int listPrime[max];

int main()
{
    GenPrime();
    int i,n,c,mid,count,j,k,total,range;
    //freopen("in.txt","r",stdin);
    while(scanf("%d%d",&n,&c)==2)
    {
        count=0;
        for(i=1;i<=n;i++)
        {
            if(prime[i])
            {
                count+=1;
                listPrime[count]=i;
            }
        }
        if(count%2==0)
        {
            total=c*2;
            printf("%d %d: ",n,c);
            if(total>count)
            {
                for(j=1;j<count;j++)
                {
                    printf("%d ",listPrime[j]);
                }
                printf("%d\n\n",listPrime[j]);
            }
            else
            {
                mid=count/2;
                mid=mid-(total/2-1);
                range=mid+total-1;
                for(j=mid;j<range;j++)
                {
                    printf("%d ",listPrime[j]);
                }
                printf("%d\n\n",listPrime[j]);
            }
        }
        else
        {
            total=c*2-1;
            printf("%d %d: ",n,c);
            if(total>count)
            {
                for(j=1;j<count;j++)
                {
                    printf("%d ",listPrime[j]);
                }
                printf("%d\n\n",listPrime[j]);
            }
            else
            {
                mid=count/2+1;
                mid=mid-(total/2);
                range=mid+total-1;
                for(j=mid;j<range;j++)
                {
                    printf("%d ",listPrime[j]);
                }
                printf("%d\n\n",listPrime[j]);
            }
        }

    }
    return 0;
}

void GenPrime()
{
    long int i,j,m;
    m=(long int)sqrt(max);
    memset(prime, 1, sizeof(prime));
    prime[0]=0;
    for(i=2;i<=m;i++)
    {
        if(prime[i])
        {
            for(j=i+i;j<max;j+=i)
                prime[j]=0;
        }
    }
}
image

No comments:

Post a Comment

Write your comment - Share Knowledge and Experience