Solution of 10783 - Odd Sum

Problem Description
source:https://uva.onlinejudge.org/external/107/10783.html

Given a range [a, b], you are to find the summation of all the odd integers in this range. For example, the summation of all the odd integers in the range [3, 9] is 3 + 5 + 7 + 9 = 24.

Input 

There can be at multiple test cases. The first line of input gives you the number of test cases, T (1 ≤ T ≤ 100). Then T test cases follow. Each test case consists of 2 integers a and b (0 ≤ a ≤ b ≤ 100) in two separate lines. 

Output 

For each test case you are to print one line of output – the serial number of the test case followed by the summation of the odd integers in the range [a, b]. 

Sample Input 







Sample Output 

Case 1: 9 
Case 2: 8

Solution:
#include<stdio.h>

int main()
{
    int c, start, end,sum,value,i,j;
    while(scanf("%d",&c)==1)
    {
       for(j=1;j<=c;j++)
       {
            scanf("%d%d",&start, &end);
            if(start%2==0)
                value=start+1;
            else
                value=start;
            sum=0;
            for(i=value;i<=end;i=i+2)
            {
                sum+=i;
            }
            printf("Case %d: %d\n",j,sum);
       }
    }
    return 0;
}
image

No comments:

Post a Comment

Write your comment - Share Knowledge and Experience