Solution of 10935 - Throwing cards away I

Problem Description
source:https://uva.onlinejudge.org/external/109/10935.html

Given is an ordered deck of n cards numbered 1 to n with card 1 at the top and card n at the bottom. The following operation is performed as long as there are at least two cards in the deck: 

     Throw away the top card and move the card that is now on the top of the deck to the bottom of the deck. 
     Your task is to find the sequence of discarded cards and the last, remaining card. 

Input 

Each line of input (except the last) contains a number n ≤ 50. The last line contains ‘0’ and this line should not be processed. 

Output 

For each number from the input produce two lines of output. The first line presents the sequence of discarded cards, the second line reports the last remaining card. No line will have leading or trailing spaces. See the sample for the expected format. 

Sample Input 


19 
10 



Sample Output 

Discarded cards: 1, 3, 5, 7, 4, 2 
Remaining card: 6 
Discarded cards: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19, 4, 8, 12, 16, 2, 10, 18, 14 
Remaining card: 6 
Discarded cards: 1, 3, 5, 7, 9, 2, 6, 10, 8 
Remaining card: 4 
Discarded cards: 1, 3, 5, 2, 6 
Remaining card: 4

Solution:
#include <algorithm>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <deque>
#include <fstream>
#include <iostream>
#include <list>
#include <map>
#include <queue>
#include <set>
#include <stack>
#include <string>
#include <vector>
#include<stdio.h>
#include<stdlib.h>

using namespace std;

int main()
{
    int i,n,last,re,set;
    queue<int> myqueue;
    while(scanf("%d",&n)==1 && n!=0)
    {
        for(i=1;i<=n;i++)
            myqueue.push(i);
        set=0;
        printf("Discarded cards:");
        while(!myqueue.empty())
        {
            last=myqueue.front();
            myqueue.pop();
            if(!myqueue.empty())
            {
                if(set==0)
                {
                    printf(" %d",last);
                    set=1;
                }
                else
                    printf(", %d",last);
                myqueue.push(myqueue.front());
                myqueue.pop();
            }
        }
        printf("\nRemaining card: %d\n",last);
    }
}

No comments:

Post a Comment

Write your comment - Share Knowledge and Experience