Solution of 11172 - Relational Operator

Problem Description
source:https://uva.onlinejudge.org/external/111/11172.html

Some operators checks about the relationship between two values and these operators are called relational operators. Given two numerical values your job is just to find out the relationship between them that is (i) First one is greater than the second (ii) First one is less than the second or (iii) First and second one is equal. 

Input 

First line of the input file is an integer t (t < 15) which denotes how many sets of inputs are there. Each of the next t lines contain two integers a and b (|a|, |b| < 1000000001). 

Output 

For each line of input produce one line of output. This line contains any one of the relational operators ‘>’, ‘<’ or ‘=’, which indicates the relation that is appropriate for the given two numbers. 

Sample Input 


10 20 
20 10 
10 10 

Sample Output 



=


Solution:
#include<stdio.h>

int main()
{
    int t, a, b,i;
    while(scanf("%d",&t)==1)
    {
        for(i=1;i<=t;i++)
        {
            scanf("%d%d",&a,&b);
            if(a<b)
                printf("<\n");
            else if(a>b)
                printf(">\n");
            else
                printf("=\n");
        }
    }
    return 0;
}
image

No comments:

Post a Comment

Write your comment - Share Knowledge and Experience