Solution of 11389 - The Bus Driver Problem

Problem Description
source:https://uva.onlinejudge.org/external/113/11389.html

In a city there are n bus drivers. Also there are n morning bus routes and n afternoon bus routes with various lengths. Each driver is assigned one morning route and one evening route. For any driver, if his total route length for a day exceeds d, he has to be paid overtime for every hour after the first d hours at a flat r taka / hour. Your task is to assign one morning route and one evening route to each bus driver so that the total overtime amount that the authority has to pay is minimized. 

Input 

The first line of each test case has three integers n, d and r, as described above. In the second line, there are n space separated integers which are the lengths of the morning routes given in meters. Similarly the third line has n space separated integers denoting the evening route lengths. The lengths are positive integers less than or equal to 10000. The end of input is denoted by a case with three 0’s. 

Output 

For each test case, print the minimum possible overtime amount that the authority must pay. Constraints 
    • 1 ≤ n ≤ 100 
    • 1 ≤ d ≤ 10000 
    • 1 ≤ r ≤ 5 

Sample Input 

2 20 5 
10 15 
10 15 
2 20 5 
10 10 
10 10 
0 0 0 

Sample Output 

50 
0


Solution:
#include <algorithm>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <deque>
#include <fstream>
#include <iostream>
#include <list>
#include <map>
#include <queue>
#include <set>
#include <stack>
#include <string>
#include <vector>
#include<stdio.h>
#include<stdlib.h>

using namespace std;

int main()
{
    long int n,d,r,evening[105],morning[105],sum, hour,i,j;
    while(scanf("%ld%ld%ld",&n,&d,&r)==3)
    {
        hour=0;
        if(n==0 && d==0 || r==0)
            break;
        for(i=0;i<n;i++)
            scanf("%ld",&morning[i]);
        sort(morning, morning+n);
        for(i=0;i<n;i++)
            scanf("%ld",&evening[i]);
        sort(evening, evening+n);
        for(i=0;i<n;i++)
        {
            sum=morning[i]+evening[n-i-1];
            if(sum>d)
              hour+=(sum-d);
        }
        printf("%ld\n",hour*r);
    }
    return 0;
}
image

No comments:

Post a Comment

Write your comment - Share Knowledge and Experience