113 - Power of Cryptography

Problem Description
source: https://uva.onlinejudge.org/external/1/113.html

Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers modulo functions of these primes. Work in this area has resulted in the practical use of results from number theory and other branches of mathematics once considered to be of only theoretical interest. 
    This problem involves the efficient computation of integer roots of numbers. 

    Given an integer n ≥ 1 and an integer p ≥ 1 you are to write a program that determines n√p, the positive n-th root of p. In this problem, given such integers n and p, p will always be of the form kn for an integer k (this integer is what your program must find).

Input 

The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairs 1 ≤ n ≤ 200, 1 ≤ p < 10101 and there exists an integer k, 1 ≤ k ≤ 109 such that kn = p. 

Output For each integer pair n and p the value n√p should be printed, i.e., the number k such that kn = p

Sample Input 


16 

27 

4357186184021382204544 

Sample Output 



1234

Solution:

#include <algorithm>
#include <cstdio>
#include <cmath>
#include<stdio.h>
#include<stdlib.h>

using namespace std;

int main()
{
    double n,p,k;
    while(scanf("%lf%lf",&n,&p)==2)
    {
        k=pow(p,1/n);
        printf("%.0lf\n",k);
    }
    return 0;
}
image

No comments:

Post a Comment

Write your comment - Share Knowledge and Experience