Solution of 445 - Marvelous Mazes

Problem Description
source: https://uva.onlinejudge.org/external/4/445.html

Your mission, if you decide to accept it, is to create a maze drawing program. A maze will consist of the alphabetic characters A-Z, * (asterisk), and spaces.

Input 

Your program will get the information for the mazes from the input file. This file will contain lines of characters which your program must interpret to draw a maze. Each row of the maze will be described by a series of numbers and characters, where the numbers before a character tell how many times that character will be used. If there are multiple digits in a number before a character, then the number of times to repeat the character is the sum of the digits before that character. 
    The lowercase letter ‘b’ will be used in the input file to represent spaces in the maze. The descriptions for different rows in the maze will be separated by an exclamation point (!), or by an end of line. 
    Descriptions for different mazes will be separated by a blank line. The input file will be terminated by an end of file.  

Output 

For each description in the input file, draw the corresponding maze as it is shown in the sample output below. There is no limit to the number of rows in a maze or the number of mazes in a file, though no row will contain more than 132 characters. 

    Print a blank line between two consecutive mazes. 

    Happy mazing! 

Sample Input 

1T1b5T!1T2b1T1b2T!1T1b1T2b2T!1T3b1T1b1T!3T3b1T!1T3b1T1b1T!5T1*1T

11X21b1X 
4X1b1X 

Sample Output 

T TTTTT 
T   T   TT
T T T  TT
T        T T
TTT       T
T        T  T
TTTTT*T

XX       X 
XXXX X

Solution:
#include <algorithm>
#include <cstdio>
#include <cmath>
#include <cstring>
#include<stdio.h>
#include<stdlib.h>

using namespace std;

int main()
{
    int i,j,value,len;
    char ch[150];
    while(gets(ch))
    {
        len=strlen(ch);
        if(len==0)
            printf("\n");
        else
        {
            value=0;
            for(i=0;ch[i]!='\0';i++)
            {
                if(isdigit(ch[i]))
                    value+=ch[i]-48;
                else if(ch[i]=='b')
                {
                    for(j=1;j<=value;j++)
                        printf(" ");
                    value=0;
                }
                else if(ch[i]=='!')
                    printf("\n");
                else
                {
                    for(j=1;j<=value;j++)
                        printf("%c",ch[i]);
                    value=0;
                }
            }
            printf("\n");
        }
        memset(ch,'\0',sizeof(ch));
    }
    return 0;
}
image

No comments:

Post a Comment

Write your comment - Share Knowledge and Experience